Ergebnis 1 bis 4 von 4

Thema: DS18B20 Temperatur-Sensor-Tester Interface Rev. C mit mini USB Kabel am Raspberry

  1. #1
    Neuer Benutzer
    Registriert seit
    26.06.2017
    Beiträge
    1
    Total Downloaded
    0

    Böse DS18B20 Temperatur-Sensor-Tester Interface Rev. C mit mini USB Kabel am Raspberry

    Hallo alle zusammen ,

    ich versuche mit allen Mitteln das Gerät DS18B20 Temperatur-Sensor-Tester Interface Rev. C am Raspberry zu betreiben.

    Am Win Rechner läuft es mit 2 Temp. Sensoren einwandfrei allerdings bekomme ich es unter dem Rasberry auf Debian Wheezy nicht zum laufen .

    Der OWServer läuft aber ich bekomme in Fhem keine Sensoren angezeigt .

    Habe alle Anleitungen aus dem I-net versucht alle ohne Erfolg.

    Hat jemand eine Funktinierende Anleitung für den Rasberry ?

    Danke in voraus.

  2. #2
    Neuer Benutzer
    Registriert seit
    22.07.2017
    Beiträge
    1
    Total Downloaded
    0
    Hallo Trebor,

    Aktuell verwende ich auf meinem Raspberry Pi das Kommandozeilentool von DIAMEX (bzw. PJRC) mit zwei DS18B20 Temperatur-Sensoren. Du kannst dieses unter https://www.led-genial.de/mediafiles...tiges/msys.zip herunterladen.

    Ich bin dabei wie folgt vorgegangen: (Quick & Dirty)
    1. Verzeichnis "/home/temp-sensor/" (aus o.g. Download-Paket) auf den Pi kopieren
    2. Build-Tools und Bibliotheken installieren: "sudo apt-get install build-essential libusb-dev libudev-dev"
    3. Im "Makefile" die Zeile "LIBS = `pkg-config libusb-1.0 libudev --libs`" durch "LIBS = `pkg-config libusb-1.0 libudev --libs libusb`" ersetzen (also "libusb" anhängen). Ansonsten hat der Linker bei mir Fehler geworfen.
    4. Programm bauen: "make clean && make" (die Fehlermeldung "No such file" kann ignoriert werden)
    5. Starten des Tools: "sudo ./TempCmd"

    Inwieweit du das Tool mit OWServer verknüpfen kannst, kann ich dir jedoch nicht sagen (kenne die Applikation nicht). Vielleicht ist es ja ausreichend, wenn du die Ausgaben in eine Datei umleitest und diese dann im OWServer lädst?

    Das Ausgabeformat des Kommandozeilen-Tools ist wie folgt: (lässt sich aber leicht ändern)
    Sensor #1 of 2: +25.8▒C Power: Parasite ID: 28 ... A3
    Sensor #2 of 2: +33.6▒C Power: Parasite ID: 28 ... 3F


    Ich glaube übrigens nicht, dass das "Temperatur-Sensor-Tester Interface Rev. C" mit 1-Wire kompatibel ist. Das Sensor-Interface wird als USB-HID Gerät erkannt und ist unter "/sys/bus/hid/devices" zu finden. Laut diversen Anleitungen im Netz, befinden sich 1-Wire Geräte unter "/sys/bus/w1/devices/". Man kann einen DS18B20 Temperatur-Sensor aber wohl auch direkt per GPIO mit dem Raspberry Pi verbinden (ohne Sensor-Interface).
    Geändert von bugi (22.07.2017 um 22:05 Uhr)

  3. #3
    Neuer Benutzer
    Registriert seit
    23.12.2017
    Beiträge
    1
    Total Downloaded
    0
    Hi,

    Versuchen das gerade auch, haben sehr lange an Schritt 4 gehangen.
    Mittlerweile läuft es zwar, es werden aber keine Sensoren erkannt...
    Alle Sensoren am Windows PC getestet, funktionieren dort einwandfrei.
    Hat es jemand zum laufen bekommen?

    VG
    Katharina

  4. #4
    Neuer Benutzer
    Registriert seit
    30.03.2018
    Beiträge
    3
    Total Downloaded
    0

    Frage

    Hi,
    hast Du schon eine Verknüpfung zum OWserver hinbekommen. Bei mir bekomme ich zwar mit dem Kommandozeilentool alls hin - allerdings momentan noch mit nur max. sechs Sensoren - aber mit dem OWserver will er einfach nicht sprechen.
    LG
    Andreas

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •