Ergebnis 1 bis 5 von 5

Thema: Pi-ODB-HAT liefert manchmal kaputte Blöcke

  1. #1
    Neuer Benutzer
    Registriert seit
    02.05.2019
    Beiträge
    3
    Total Downloaded
    0

    Pi-ODB-HAT liefert manchmal kaputte Blöcke

    Moin,
    ich nutze den HAT um meinen Ioniq Electric abzufragen. Bei bestimmten Abfragen bekomme ich manchmal unvollständige Daten.
    Beispiel:
    7EE10196180C366C000
    0002331700 <<<<< ?
    7EC2600CF830000C819
    7EC270061724209018B
    7EC280000000003E800

    Was kann da los sein? Laut RX-Filter (7EE) und RX-Maske (7FF) sollte ich die 7ECxxx garnicht zu sehen bekommen ...

  2. #2
    Administrator Avatar von Folker
    Registriert seit
    25.06.2005
    Beiträge
    2.002
    Total Downloaded
    0
    Hmm, Du benutzt das Pi-OBD-Modul ohne HHGui mit eigener Initialisierung, die Du nicht angegeben hast. Die gesendete CAN Botschaft ist auch nicht dabei. Ich würde Dich bitten, Dich direkt an den Software Autor Thomas Beck zu wenden, der steht im Stoff und kann möglicherweise weiterhelfen.
    OBD2 Hardware-Support: Qualifizierte Antwort gewünscht? Dazu brauchen wir natürlich so viele Infos wie es geht: Marke/Baujahr/Kraftstoffart/Interface/Problem/ Laptop/Betriebssystem/Anwenderprogramm/ Fehlermeldung/spezifische Angaben. Wichtig: Interface bei laufendem Motor gestestet? Wurde es von der Soft erkannt?Nein?Anleitung gelesen? Porteinstellung

  3. #3
    Neuer Benutzer
    Registriert seit
    02.05.2019
    Beiträge
    3
    Total Downloaded
    0
    So, endlich wieder ein wenig Zeit für dieses Thema ...
    Hat der Thomas Beck auch die Firmware auf dem Pi-HAT geschrieben? Oder nur die Software die dann auf 'nem Arduino oder Pi läuft? Das hab ich so auf die schnelle nicht aus den Artikeln herausgelesen ...

  4. #4
    Administrator Avatar von Folker
    Registriert seit
    25.06.2005
    Beiträge
    2.002
    Total Downloaded
    0
    Firmware ist von uns. Alles andere von Thomas.
    OBD2 Hardware-Support: Qualifizierte Antwort gewünscht? Dazu brauchen wir natürlich so viele Infos wie es geht: Marke/Baujahr/Kraftstoffart/Interface/Problem/ Laptop/Betriebssystem/Anwenderprogramm/ Fehlermeldung/spezifische Angaben. Wichtig: Interface bei laufendem Motor gestestet? Wurde es von der Soft erkannt?Nein?Anleitung gelesen? Porteinstellung

  5. #5
    Neuer Benutzer
    Registriert seit
    02.05.2019
    Beiträge
    3
    Total Downloaded
    0
    Alles klar, dann seid ihr wohl die richtigen Ansprechpartner.

    Ich spreche den Hat mit python per python-serial und pexpect an. Letztendlich sende ich das jeweilige Kommando und lese dann bis ich eine Zeile mit '>' finde.
    Meine Init-Sequenz ist:

    ATRST
    ATE0
    ATL1
    ATOHS0
    ATH1
    ATST64
    ATP6
    ATONI1
    ATCM7FF

    Dann sekündlich:
    AT!10
    (OBD-Spannung auslesen, hier kommen manchmal noch Daten vom 2180 anstelle des OK, bzw. das OK ist da irgendwo mitten drin)
    ATCR7EC
    2101
    (Rückgabe lesen)
    2105
    (Rückgabe lesen)
    ATCR7EE
    2180
    (Rückgabe lesen, manchmal sieht das aus wie im ersten Post gezeigt, danach ist dann auch der AT!10 meistens betroffen)


    Beim nächsten Zyklus ist dann wieder in Ordnung. Das Fahrzeug ist ein Hyundai Ioniq Electric, die Kommandos lesen Teile des Batteriemanagements und der Klimaanlage aus.



    Passt nicht ganz hier rein, aber sehe ich das richtig, dass es beim Hat keinen Monitor-Mode (ala ATMA beim ELM327) gibt? Es gibt da Fahrzeuge, die einfach alle Info Broadcasten und man einfach nur mithören müsste um an alle Infos zu kommen.

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •