Ergebnis 1 bis 4 von 4

Thema: CDC 2009 mit AGV2055 v5.1 an Mercedes R170: keine Verbindung

  1. #1
    Neuer Benutzer
    Registriert seit
    08.03.2010
    Beiträge
    2
    Total Downloaded
    0
    Hallöchen!

    Also irgendwie kann ich mich mit meinem Dx25 nicht verbinden an meinen Mercedes. MoDiag funktioniert direkt problemlos. Der Wagen ist Baujahr 2001.

    Ich hab die interne ID des Interfaces auch schon einige male geändert:
    - ursprünglich: DIAMEX DX25 v5.1
    - AGV2055 v5.1 <- aktuell
    - ELM32
    - ELM323

    Keine Kennung funktioniert. Com4 ist korrekt und virtueller Port wurde aktiviert, da es über ein USB Kabel läuft. Baudrate steht auf 9600. Sonst wurde nichts geändert. Das log sieht wie folgt aus bei einer Verbindung mittels AGV2055:

    [GeneralProgram 44.0625] @_InitializeCultureInfo:de-DE
    [GeneralProgram 44.0693] @_InitializeControls()
    [Obd2Communication 57.0017] @_Obd2InterfaceAGV2055::Obd2InterfaceAGV()
    [DataAccess 57.0040] @_DataAccessRS232::Open
    [DataAccess 57.0040] Open COM port (COM4:9600)
    [Obd2Communication 57.0348] @_Obd2InterfaceAGV2055::InitializeInterface
    [DataAccess 57.0349] @_DataAccessRS232::Write
    [DataAccess 57.0349] SEND:ATZ
    [DataAccess 57.0353] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 57.0353] Read line...
    [MBExceptions 01.0975] MBGeneralException: (No interface available)
    [DataAccess 01.0976] @_DataAccessRS232::Close
    [DataAccess 01.0976] Close COM port
    [DataAccess 02.0025] @_DataAccessRS232::Close
    [GeneralProgram 36.0237] @_SaveConfiguration()
    [GeneralProgram 43.0921] @_InitializeCultureInfo:de-DE
    [GeneralProgram 43.0980] @_InitializeControls()

    und bei einer Verbindung mit AGV4000:

    [GeneralProgram 00.0997] @_InitializeCultureInfo:de-DE
    [GeneralProgram 01.0055] @_InitializeControls()
    [Obd2Communication 05.0722] @_Obd2InterfaceAGV4000::Obd2InterfaceAGV()
    [DataAccess 05.0743] @_DataAccessRS232::Open
    [DataAccess 05.0743] Open COM port (COM4:9600)
    [Obd2Communication 06.0045] @_Obd2InterfaceAGV4000::InitializeInterface
    [DataAccess 06.0047] @_DataAccessRS232::Write
    [DataAccess 06.0047] SEND:ATZ
    [DataAccess 06.0050] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 06.0050] Read line...
    [DataAccess 06.0675] RET:ATZ
    AGV2055 v5.1
    [DataAccess 06.0677] @_DataAccessRS232::Write
    [DataAccess 06.0677] SEND:ATL0
    [DataAccess 06.0679] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 06.0679] Read line...
    [DataAccess 06.0691] RET:ATL0
    OK
    [DataAccess 06.0691] @_DataAccessRS232::Write
    [DataAccess 06.0691] SEND:ATE0
    [DataAccess 06.0692] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 06.0692] Read line...
    [DataAccess 06.0705] RET:ATE0
    OK
    [DataAccess 06.0705] @_DataAccessRS232::Write
    [DataAccess 06.0705] SEND:0100
    [DataAccess 06.0706] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 06.0706] Read line...
    [DataAccess 10.0227] RET:BUS INIT: ...OK
    41 00 BE 1F F8 10
    [DataAccess 10.0227] @_DataAccessRS232::Write
    [DataAccess 10.0227] SEND:ATH1
    [DataAccess 10.0228] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 10.0228] Read line...
    [DataAccess 10.0240] RET:OK
    [DataAccess 10.0240] @_DataAccessRS232::Write
    [DataAccess 10.0241] SEND:ATI
    [DataAccess 10.0242] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 10.0242] Read line...
    [DataAccess 10.0263] RET:AGV2055 v5.1
    [Obd2Communication 10.0264] @_Obd2InterfaceAGV4000::ReadChipIdent
    [DataAccess 10.0264] @_DataAccessRS232::Write
    [DataAccess 10.0264] SEND:ATI
    [DataAccess 10.0265] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 10.0265] Read line...
    [DataAccess 10.0286] RET:AGV2055 v5.1
    [Obd2Communication 10.0286] @_Obd2InterfaceAGV4000::ReadChipVersion
    [Obd2Communication 10.0312] @_Obd2InterfaceAGV4000::ReadChipSerialNumber
    [DataAccess 10.0312] @_DataAccessRS232::Write
    [DataAccess 10.0312] SEND:AT!00
    [DataAccess 10.0313] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 10.0313] Read line...
    [DataAccess 10.0339] RET:59360-18893-189
    [Obd2Communication 10.0339] @_Obd2InterfaceAGV4000::ReadChipSerialNumber
    [DataAccess 10.0339] @_DataAccessRS232::Write
    [DataAccess 10.0339] SEND:AT!00
    [DataAccess 10.0339] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 10.0340] Read line...
    [DataAccess 10.0366] RET:59360-18893-189
    [Obd2Communication 10.0384] @_Obd2InterfaceAGV4000::ReadChipIdent
    [DataAccess 10.0384] @_DataAccessRS232::Write
    [DataAccess 10.0384] SEND:ATI
    [DataAccess 10.0386] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 10.0386] Read line...
    [DataAccess 10.0407] RET:AGV2055 v5.1
    [Obd2Communication 10.0410] @_Obd2InterfaceAGV4000::ReadFoundProtocol
    [DataAccess 10.0410] @_DataAccessRS232::Write
    [DataAccess 10.0411] SEND:ATN
    [DataAccess 10.0412] @_DataAccessRS232::ReadToStrWithException
    [DataAccess 10.0412] Read line...
    [DataAccess 10.0421] RET:?
    [Obd2Communication 10.0423] @_Obd2InterfaceAGV4000::ProtocolType:set
    [Obd2Communication 10.0423] @_Obd2InterfaceAGV4000::ProtocolType:get
    [Obd2Communication 10.0423] @_Obd2InterfaceAGV4000::ProtocolType:get
    [MBExceptions 10.0425] MBGeneralException: (Der Car Diagnostic Center konnte kein Protokol aus dem KFZ auslesen. Bitte stellen Sie sicher, dass das KFZ OBD2 Kompatibel ist oder das die Verbindungskonfiguration korrekt eingestellt wurde.)
    [DataAccess 10.0426] @_DataAccessRS232::Close
    [DataAccess 10.0426] Close COM port
    [DataAccess 10.0479] @_DataAccessRS232::Close

    Wäre toll wenn ihr mir helfen könntet. :)

    Viele Grüße
    Sebastian

  2. #2
    Administrator Avatar von Folker
    Registriert seit
    25.06.2005
    Beiträge
    2.003
    Total Downloaded
    0
    da muss Marcel mal drüberschauen.
    Die Kennung braucht man nur ändern wenn der Software unsere Interface nicht bekannt sind. Bei CDC ist das nicht nötig.
    OBD2 Hardware-Support: Qualifizierte Antwort gewünscht? Dazu brauchen wir natürlich so viele Infos wie es geht: Marke/Baujahr/Kraftstoffart/Interface/Problem/ Laptop/Betriebssystem/Anwenderprogramm/ Fehlermeldung/spezifische Angaben. Wichtig: Interface bei laufendem Motor gestestet? Wurde es von der Soft erkannt?Nein?Anleitung gelesen? Porteinstellung

  3. #3
    Neuer Benutzer
    Registriert seit
    08.03.2010
    Beiträge
    2
    Total Downloaded
    0
    Mit CDC 2008 kann ich mich übrigens verbinden, allerdings sind die Sensordaten meiner Ansicht nach fehlerhaft, die CDC 2008 interpretiert. So hab ich z.B. wenn ich stehe angeblich 13km/h drauf.
    CDC 2009 funktioniert immer noch nicht :)

  4. #4
    Administrator Avatar von Folker
    Registriert seit
    25.06.2005
    Beiträge
    2.003
    Total Downloaded
    0
    ich habe von Marcel leider auch lange nichts mehr gehört - er tourt sicher wieder irgendwo auf der Welt rum ;)
    OBD2 Hardware-Support: Qualifizierte Antwort gewünscht? Dazu brauchen wir natürlich so viele Infos wie es geht: Marke/Baujahr/Kraftstoffart/Interface/Problem/ Laptop/Betriebssystem/Anwenderprogramm/ Fehlermeldung/spezifische Angaben. Wichtig: Interface bei laufendem Motor gestestet? Wurde es von der Soft erkannt?Nein?Anleitung gelesen? Porteinstellung

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •